用mamp Pro 的PHP版本替换Mac系统自带的PHP

思路是用mamp的PHP文件路径替换Mac系统自带的PHP的环境变量路径。

文章编写是的相关版本;

1、系统自带的PHP版本为5.6.30

2、mamp Pro 版本

mamp Pro 4.2.1 、PHP最高版本为 7.1.8

3、操作系统版本

macOS Sierra 10.12.4

操作步骤

1、获取mamp Pro的PHP 路径 一般是:在  /Applications/MAMP/bin/php/<span style="color: #0000ff;">php7.1.8/bin/ ;

2、新建或编辑个人用户下的环境变量配置文件。

3、最后插入环境变量输出配置并保存( wq )。

4、载入环境变量配置文件是更改生效。

5、检查是否生效

 

  • 注:

如果终端用的是zsh 的话需要修改 ~/.zshrc 文件来生效。即把 export PATH="/Applications/MAMP/bin/php/php7.1.8/bin//bin:$PATH"  插入到 vim ~/.zshrc 的最后面,再  source ~/.zshrc 即可。